IMCDb Forum
General  » Site moving to a new server
Category :  
« Previous topic
Reminder of the previous message
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 17/03/2018 @ 23:38:49, By antp
The new server is closer to you (now it is in Montreal, before it was in France) so the response time on each request (page or image) should be shorter for North-American users.
Also, it is running on PHP 7 instead of 5, which is a little faster, though that I'm not sure that for a site with basic code like IMCDb the difference is really noticeable.


I'm not sure what you mean by "tabbing the page" :figti:

Latest Edition: 17/03/2018 @ 23:40:25


Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 17/03/2018 @ 23:43:16, By night cub
It is now allowing me to validate thanks.
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 18/03/2018 @ 04:21:10, By Exiv96
There seems to be a problem uploading pictures. I was trying to merge some entries, and got this message.

Warning: file_put_contents(pics/temp/i001123918jpg): failed to open stream: No such file or directory in /var/www/imcdb/upload.php on line 294
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 18/03/2018 @ 08:56:22, By sixcyl
I've tried to add a new film, but I couldn't and here is the messages I got:

Admin : New movie
Data too long for column 'movie_title' at row 1
INSERT INTO movie_s (movie_id,movie_year,movie_year2,movie_title,movie_type) VALUES (66252,1971,0,'Una prostituta al servizio del pubblico e in regola con le leggi dello stato',0)

So what do we do?

Sixcyl
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 18/03/2018 @ 10:18:31, By antp
@Exiv96 > should be ok
@Sixcyl > title too long (max length = 75) ; previously it was truncating automatically, I suppose that now by default it refuse the data, I'm searching how to make that silently.
edit: done

Latest Edition: 18/03/2018 @ 10:31:00
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 18/03/2018 @ 15:09:22, By antp
HTTPS should be fine now.
You can use https://imcdb.org or https://www.imcdb.org (as you prefer)
As usual, please report any error you notice, but also the culprit page if at some point you end up on the non-HTTPS version of the site (normally all links on the site should keep you on the HTTPS version).
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 18/03/2018 @ 17:55:17, By ElSaxo
https version isn't switched automatically for me if i open the site from my favourites. can you make https connection by default over http?
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 18/03/2018 @ 19:10:31, By mok
https://pics.imcdb.org/21598/347222414924555290312018-03-19199782132020430.jpg beforehttps://pics.imcdb.org/21598/347222414924555290312018-03-19199782132020439.jpg after
The facebook like button on the vehicle page is missing......
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 18/03/2018 @ 19:53:45, By antp
https version isn't switched automatically for me if i open the site from my favourites. can you make https connection by default over http?


I'll maybe do that later, when I'm sure that all works fine, but currently it is not forced.
If you wish to use the HTTPS version modify your favourite :grin:
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 18/03/2018 @ 19:57:56, By antp

The facebook like button on the vehicle page is missing......


Indeed, thanks. It is fixed now, however as they seem to separate HTTP & HTTPS in their stats all the likes are now "lost" because set on HTTP-version of the pages :ohwell:
Or maybe they'll come back if at some point they refresh the data, seeing that now the pages are available as HTTPS.
edit: I'll keep the HTTP version for Facebook for now, I'll see that later when forcing HTTPS version.

Latest Edition: 18/03/2018 @ 20:11:17
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 19/03/2018 @ 12:59:25, By rjluna2
I'm not sure what you mean by "tabbing the page" :figti:


Tabbing the page which it means to open another web page at the same browser instance.

https://en.wikipedia.org/wiki/Tab_(GUI)

Latest Edition: 19/03/2018 @ 12:59:41
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 19/03/2018 @ 18:33:28, By antp
I know what tabs are, I wasn't sure what you meant by "tabbing" :grin:
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 20/03/2018 @ 02:07:34, By chicomarx
should be shorter for North-American users.

For me Roubaix was a lot closer than Canada though. Just sayin'. :whistle:

I do believe the main images take a fraction longer to load.
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 20/03/2018 @ 13:09:17, By antp
Sure, for us it is slightly slower then :grin: The transfer speed should not be impacted (for 100 KB pic...), only the response time on page/image request may have an impact (what rjluna mentioned: the start of loading of a page)
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 29/03/2018 @ 05:06:58, By eLMeR
[...] The hardware of the new server is similar to the old one, but with a newer version of the OS I'll be able to easily enable HTTPS (finally!) [...]

I did it on my own server a few weeks ago, thanks to Let's Encrypt (as you did for the IMCDb): a really easy move!
With their encryption during their transfert and in the corresponding cookie, our credentials are now (almost) entirely protected when we log into the IMCDb :wink:

Latest Edition: 29/03/2018 @ 05:13:21
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 29/03/2018 @ 09:09:25, By antp
It was a little less easy here due to the use of lighttpd rather than apache or nginx, but after a few tries I found how to make it work seamlessly
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 01/04/2018 @ 23:31:33, By eLMeR
Sounds indeed a bit more tricky than with Apache2. But still relatively easy when compared to some other server configurations: try Postfix if you like headaches :wink:

Will lighttpd be enough for the IMCDb, all the more with the (most probably heavier) code of the NextGen? I use it on my computer for "internal" tools and for testing html/php pages and scripts, but feel more "comfortable" when having an Apache for online sites...
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 01/04/2018 @ 23:57:19, By antp
try Postfix if you like headaches :wink:

I use it and didn't really have problems (though that I do not use it as relaying SMTP)


Will lighttpd be enough for the IMCDb, all the more with the (most probably heavier) code of the NextGen? I use it on my computer for "internal" tools and for testing html/php pages and scripts, but feel more "comfortable" when having an Apache for online sites...

lighttpd is much lighter than Apache, taking less CPU (this server runs only on an i3), I don't think it would be quickly limited.
In case at some point it is not enough I could still switch to Nginx.
The new site is more complex, but the database is much better designed (using tables for car makes, models, etc. instead of a rather "plain" system as current with simple text field for each role), so it may reduce the load on the SQL database (currently using much more CPU than the web server).

Latest Edition: 01/04/2018 @ 23:58:49
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 17/05/2018 @ 14:15:29, By ElSaxo


I'll maybe do that later, when I'm sure that all works fine, but currently it is not forced.
If you wish to use the HTTPS version modify your favourite :grin:


So... Both Google and Bing now redirects to https version... Time has finally come to switch on https by default?
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 18/05/2018 @ 00:07:25, By antp
They redirect to HTTPS because I specified that version in the canonical URL in the header.
I should force HTTPS for the login, that's on my to-do list.
Direct link to this message Edit  Quote  Add this message as quote for multiple quotes  Delete  Top  Bottom
Site moving to a new server
Published 19/05/2018 @ 18:05:40, By ElSaxo
Can I say that I don't see the logic behind forcing https only for the login page and not the entire site?
Add Reply  - Category :  
Sign In  :: Sign Up  :: Lost your login or your password?
KelCommunity.be :: © 2004-2018 Akretio SPRL :: Powered by Kelare